Posts Tagged PowerShell 3.0

Cannot add Windows PowerShell snap-in VeeamPSSnapin


You may encounter an error Cannot add Windows PowerShell snap-in VeeamPSSnapin when you run PowerShell scripts on Veeam Backup & Replication to start Backup Jobs after an upgrade from Veeam  Backup v6.x to v6.5

Symptoms:

  • PowerShell Scripts scheduled via Task Scheduler doesn’t start automatically.
  • If you run the script manually via Veeam PowerShell snap-in VeeamPSSnapin, you will receive an error. Cannot add Windows PowerShell snap-in VeeamPSSnapin. But the job will start.

Solution:

Upgrade to PowerShell 3.0 by installing Windows Management Framework 3.0 (http://www.microsoft.com/en-us/download … x?id=34595) which supports .Net 4.0 natively.

Advertisements

, , , , , , , ,

Leave a comment